【Expo】expo start で起動に失敗した???

React-Native
この記事は約3分で読めます。

こんにちは。やらしみずです。

今日も元気にReactNativeで開発を進めていくぞ!!、、、と思った矢先に、こんなエラーが出てしまって、ビルドが完了しませんでした。


$ expo start 
┌──────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────┐
│                                                                                                                                          │
│   There is a new version of expo-cli available (3.15.4).                                                                                 │
│   You are currently using expo-cli 3.13.5                                                                                                │
│   Install expo-cli globally using the package manager of your choice; for example: `npm install -g expo-cli` to get the latest version   │
│                                                                                                                                          │
└──────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────┘
Starting project at /Users/shimizuryouta/workspace/speedbox
Property 'expo' in app.json for project at path /Users/yarashimizu/speedbox is not an object. Please make sure app.json includes a managed Expo app config like this: {"expo":{"name":"My app","slug":"my-app","sdkVersion":"..."}}
Set EXPO_DEBUG=true in your env to view the stack trace.

なんだこれ!!と思ったのですが、ただ単純に間違えたディレクトリで起動をしようとしたためこれが出てきてしまったようです。

私の場合
(正) cd /workspace/react-native/speedbox && expo start
(誤) cd /workspace/speedbox && expo start

app.jsonが無いぞとエラーが出てきたら、とりあえずちゃんとプロジェクトの中に入れているか、pwdで確認しよう(自戒)

コメント

タイトルとURLをコピーしました